22 June 2011

[Updated] Compatibility With Firefox 5

Update: Clippings is now compatible with Thunderbird 5. Also, the portable edition of Clippings, available from the Clippings web site, is now compatible with Portable Firefox 5 and Portable Thunderbird 5.

Yesterday, Mozilla unveiled the newest version of Firefox. Firefox 5 is the first release from the new rapid release development cycle that aims to push out new releases more frequently.

All extensions from AE Creations -- Clippings, Delicious Post, Panic Button and Send Tab URLs -- are compatible with Firefox 5.

Future Firefox Releases

For now, the policy for extension compatibility with upcoming Firefox releases will remain unchanged. They will not be compatible with the nightly (Aurora) builds. Extensions will be made compatible with beta releases once they have been tested and confirmed to be working with the beta releases.

What About Thunderbird 5?

Clippings currently is not compatible with the beta release of Thunderbird 5. This will be fixed once it is tested and confirmed functional on that release.